about summary refs log tree commit diff
path: root/fun/paroxysm/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-08-01T23·26+0100
committertazjin <mail@tazj.in>2020-08-02T02·16+0000
commit194c498d53ed68a9c70d548008e60eb7bdcbd59a (patch)
tree212947662db08737d228996b5ed707a172d8a618 /fun/paroxysm/default.nix
parent660a02947f91fd88901ee32e708f0004b45313ef (diff)
refactor(paroxysm): Explicitly macro imports, no more 'extern crate' r/1542
Removes all but one occurence of `extern crate`, to conform with Rust
2018.

The last one is necessary because Diesel is a giant jungle of
complicated macros re-exported from private crates, and the current
version makes it hard to import those directly instead.

Change-Id: Id14165a456d5c3ce6f7a4e0222c611640113eb11
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1549
Tested-by: BuildkiteCI
Reviewed-by: kanepyork <rikingcoding@gmail.com>
Diffstat (limited to 'fun/paroxysm/default.nix')
-rw-r--r--fun/paroxysm/default.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/fun/paroxysm/default.nix b/fun/paroxysm/default.nix
index 214f2fdcba..b6eefc7a2e 100644
--- a/fun/paroxysm/default.nix
+++ b/fun/paroxysm/default.nix
@@ -7,5 +7,10 @@ pkgs.naersk.buildPackage {
   name = "paroxysm";
   version = "0.0.1";
   src = ./.;
-  buildInputs = [pkgs.openssl pkgs.pkgconfig pkgs.postgresql.lib];
+
+  buildInputs = with pkgs; [
+    openssl
+    pkgconfig
+    postgresql.lib
+  ];
 }