about summary refs log tree commit diff
path: root/fun/🕰️/default.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2021-05-29T14·02+0200
committersterni <sternenseemann@systemli.org>2021-05-29T19·13+0000
commit8418e01a840cd2d6f55291929b126b1e6b1f028f (patch)
tree7e4b759018c19df4766a1a2555b8e9bee94f3fef /fun/🕰️/default.nix
parentf60d174591a2fdf3de8fe96b9f3bb890a000bfe8 (diff)
feat(fun/🕰️): get the time as an emoji clock face r/2633
This small tool prints the current time rounded to half-hour precision
as an emoji clock face and exists. It can use both the local time zone
and UTC. Additionally it supports a pseudo dot time format.

Via fun.🕰️.lib we reexpose the internal library which allows conversion
from LOCAL-TIME:TIMESTAMP to an emoji clock face — maybe we'll want to
integrate this into //web/panettone?

//fun/🕰️ is the spritual (and actual) successor to
<https://github.com/sternenseemann/unicode_clock>.

It likely only works in SBCL due to its heavy usage of unicode symbol
names.

Change-Id: I44204107a14f99b04b0c5290d88e8659f013f423
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3164
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'fun/🕰️/default.nix')
-rw-r--r--fun/🕰️/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/fun/🕰️/default.nix b/fun/🕰️/default.nix
new file mode 100644
index 0000000000..d6fd5fc35e
--- /dev/null
+++ b/fun/🕰️/default.nix
@@ -0,0 +1,36 @@
+{ depot, ... }:
+
+let
+  inherit (depot.nix)
+    buildLisp
+    ;
+
+  lib = buildLisp.library {
+    name = "lib🕰️";
+    deps = [
+      depot.third_party.lisp.local-time
+    ];
+
+    srcs = [
+      ./lib.lisp
+    ];
+  };
+
+  bin = buildLisp.program {
+    name = "🕰️";
+    deps = [
+      depot.third_party.lisp.unix-opts
+      depot.lisp.klatre
+      (buildLisp.bundled "uiop")
+      lib
+    ];
+
+    srcs = [
+      ./bin.lisp
+    ];
+
+    main = "🕰️.bin:🚂";
+  };
+in bin // {
+  inherit lib;
+}