about summary refs log tree commit diff
path: root/emacs.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2018-09-19T20·59+0200
committerVincent Ambo <mail@tazj.in>2018-09-19T20·59+0200
commitb19b1590e5cf19cae1f3d0511eb24344a1313d09 (patch)
tree958cd0af9ca95aa07ff54a4c68a92b3a5713ad4e /emacs.nix
parent8d918e48eb1975a7fb477bac7ec7d4a06df6d3c9 (diff)
chore(emacs): Bump EXWM & XELB to most recent development versions
Diffstat (limited to 'emacs.nix')
-rw-r--r--emacs.nix31
1 files changed, 26 insertions, 5 deletions
diff --git a/emacs.nix b/emacs.nix
index 4d99949234..3dad08b24d 100644
--- a/emacs.nix
+++ b/emacs.nix
@@ -152,18 +152,39 @@ sly = emacsPackagesNg.melpaBuild {
   '';
 };
 
+# As the EXWM-README points out, XELB should be built from source if
+# EXWM is.
+xelb = melpaBuild {
+  pname   = "xelb";
+  ename   = "xelb";
+  version = "0.15";
+
+  packageRequires = [ cl-generic emacs ];
+
+  src = fetchFromGitHub {
+    owner  = "ch11ng";
+    repo   = "xelb";
+    rev    = "b8f168b401977098fe2b30f4ca32629c0ab6eb83";
+    sha256 = "1ack1h68x8ia0ji6wbhmayrakq35p5sgrrl6qvha3ns3pswc0pl9";
+ };
+};
+
 # EXWM pinned to a newer version than what is released due to a
 # potential fix for ch11ng/exwm#425.
-exwm = emacsPackagesNg.exwm.overrideAttrs(_: {
-  version = "master";
+exwm = melpaBuild {
+  pname   = "exwm";
+  ename   = "exwm";
+  version = "0.19";
+
+  packageRequires = [ xelb ];
 
   src = fetchFromGitHub {
     owner  = "ch11ng";
     repo   = "exwm";
-    rev    = "dd57c5eebb213c29c3b250634e316abf4917a19b";
-    sha256 = "0y2fb87pcj3rb56i8pmlz0422pl1d6prx25p707v0ihkjvhnr6y0";
+    rev    = "472f7cb82b67b98843f10c12e6bda9b8ae7262bc";
+    sha256 = "19gflsrb19aijf2xcw7j2m658qad21nbwziw38s1h2jw66vhk8dj";
  };
-});
+};
 
 in emacsWithPackages(epkgs:
   # Actual ELPA packages (the enlightened!)