about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-09T10·58+0000
committerVincent Ambo <tazjin@google.com>2019-12-09T10·58+0000
commite9431682b2da6fc5085961e42b654bb8b833b879 (patch)
treea5cbac7bffbbc5a777b4a2dd9eb895cf76ac94a3 /default.nix
parenta1ac598fa0782e22c9fb9c27719a50e543757f41 (diff)
refactor: Move CI setup to separate Nix file r/111
Instead of polluting the repository namespace with the list of CI
projects, move that to a separate file.

Currently the list of projects to be built by CI is still hardcoded,
but this will be fixed soon.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/default.nix b/default.nix
index 6652d7834d..f69c96ab4c 100644
--- a/default.nix
+++ b/default.nix
@@ -12,15 +12,6 @@ let
   # package set is not available here.
   fix = f: let x = f x; in x;
 
-  # Derivations that have `meta.enableCI` set to `true` should be
-  # built by the CI system on every commit. This code implements
-  # filtering of all derivations in the local sets against this
-  # condition.
-  filterCI = lib: pkgs: let
-    inherit (lib) collect isDerivation filterAttrsRecursive;
-    ciCondition = _: x: (!isDerivation x) || ((x ? meta.enableCI) && (x.meta.enableCI));
-  in collect isDerivation (filterAttrsRecursive ciCondition pkgs);
-
   # Global configuration that all packages are called with.
   config = pkgs: {
     inherit pkgs;
@@ -45,19 +36,6 @@ in fix(self: {
 
   # Elevate 'lib' from nixpkgs
   lib = import (self.third_party.nixpkgsSrc + "/lib");
-
-  # Collect all projects that should be built by CI
-  # ciProjects = (filterCI self.lib self.services)
-  #   ++ (filterCI super.lib self.tools)
-  #   ++ (filterCI super.lib self.third_party);
-  # TODO(tazjin): re-enable automatic filtering for this, requires
-  # read-tree fixes
-  ciProjects = with self; [
-    services.tazblog
-    services.nixcon-demo
-    tools.kms_pass
-    tools.blog_cli
-  ];
 }
 
 # Add local packages as structured by readTree