about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-08-19T23·26+0100
committerVincent Ambo <tazjin@google.com>2019-08-19T23·26+0100
commitb856648127e89321db338344019544a4fcdcbf93 (patch)
treed0ec017298c9faec2592d5a73aaa66a897feb1c4 /default.nix
parent11fcf6229751eb266485cbba78d30aced1787d14 (diff)
feat(tools): Introduce ormolu for formatting Haskell code r/45
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index e9288179c9..5d9f128208 100644
--- a/default.nix
+++ b/default.nix
@@ -19,6 +19,12 @@ let
     gitAppraise = pkgs.callPackage ./third_party/go/git-appraise/git-appraise {};
     nixery = import ./third_party/nixery.nix { pkgs = super; };
     terraform-gcp = pkgs.terraform_0_12.withPlugins(p: [ p.google ]);
+    ormolu = import (super.fetchFromGitHub {
+      owner = "tweag";
+      repo = "ormolu";
+      rev = "a7076c0f83e5c06ea9067b71171859fa2ba8afd9";
+      sha256 = "1p4n2ja4ciw3qfskn65ggpy37mvgf2sslxqmqn8s8jjarnqcyfny";
+    }) { pkgs = super; };
   };
 
   # The pinned commit here is identical to the public nixery.dev