about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-08-15T15·07+0100
committerVincent Ambo <tazjin@google.com>2019-08-15T15·07+0100
commita20daf87265a62b494d67f86d4a5199f14394973 (patch)
tree576d8c20fc82c6177bea9f8035c729c543624847 /default.nix
parent77f0b5021d51f2ea20496f5ce60451dcf929541e (diff)
chore(nix): Remove overridden GHC r/30
We're not going down the Bazel route here, so this is not going to be
necessary.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix41
1 files changed, 13 insertions, 28 deletions
diff --git a/default.nix b/default.nix
index 7c264653d7..b433b1dfba 100644
--- a/default.nix
+++ b/default.nix
@@ -1,40 +1,25 @@
-# This file sets up the top-level package set by merging all local
-# packages into the nixpkgs top-level.
+# This file sets up the top-level package set by merging all local packages into
+# the nixpkgs top-level.
+#
+# This makes packages accessible via the Nixery instance that is configured to
+# use this repository as its nixpkgs source.
 
 let
   localPkgs = super: pkgs: {
     # Local projects should be added here:
-    tazjin.tazblog = import ./services/tazblog { inherit pkgs; };
-    tazjin.gemma = import ./services/gemma { inherit pkgs; };
+    tazblog = import ./services/tazblog { inherit pkgs; };
+    gemma = import ./services/gemma { inherit pkgs; };
 
-    # Third-party projects (either vendored or modified from nixpkgs)
-    # should be added here:
-    thirdParty.gitAppraise = pkgs.callPackage ./third_party/go/git-appraise/git-appraise {};
-    thirdParty.ghc = pkgs.haskell.packages.ghc865.ghcWithPackages(p: with p; [
-      acid-state
-      base64-bytestring
-      blaze-html
-      containers
-      cryptohash
-      hamlet
-      happstack-server
-      ixset
-      markdown
-      mtl
-      network
-      network-uri
-      options
-      rss
-      safecopy
-    ]);
+    # Third-party projects (either vendored or modified from nixpkgs) go here:
+    gitAppraise = pkgs.callPackage ./third_party/go/git-appraise/git-appraise {};
   };
 
-  # TODO(tazjin): It might be preferable to pin a specific commit of
-  # nixpkgs, but for now the assumption will be that a single release
-  # channel is reasonably stable.
-  nixpkgsVersion = "nixos-19.03";
+  # The pinned commit here is identical to the public nixery.dev
+  # version, since popularity data has been generated for that.
+  nixpkgsVersion = "88d9f776091896cfe57dc6fbdf246e7d27d5f105";
   nixpkgs = "https://github.com/NixOS/nixpkgs-channels/archive/${nixpkgsVersion}.tar.gz";
 
 in { ... } @ args: import (builtins.fetchTarball nixpkgs) (args // {
     overlays = [ localPkgs ];
+    config.allowUnfree = true;
 })