about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-05-01T16·18+0000
committerVincent Ambo <github@tazj.in>2019-05-01T16·24+0100
commit8abe03de3c75dd1dc1f2f65ff71b1ec3888208c2 (patch)
tree70cb9d2bd8514e1aa7d8e7f3afafa60066d13dc8 /default.nix
parent245d3bd1548b9cd11e3d2bf9bd93550477da1541 (diff)
fix(build): Make Nix build work with recent nixpkgs
Changes in the Go build environment for Nix have caused the parallel
vetting to run in a subshell which does not have the required function
definitions.

This commit fixes the error by not running vet in parallel (there's no
point to that anyways as the project is tiny).
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index e2c1a5650f..b2f1c284fb 100644
--- a/default.nix
+++ b/default.nix
@@ -23,7 +23,9 @@ with pkgs; buildGoPackage rec {
   # Enable checks and configure check-phase to include vet:
   doCheck = true;
   preCheck = ''
-    getGoDirs "" | parallel -j $NIX_BUILD_CORES buildGoDir vet
+    for pkg in $(getGoDirs ""); do
+      buildGoDir vet "$pkg"
+    done
   '';
 
   meta = with lib; {