about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2019-11-30T03·57-0500
committerGriffin Smith <root@gws.fyi>2019-11-30T03·57-0500
commit7d8ce026a2acc5a4d208110750be188f0ce5591c (patch)
tree7a2fc4080eae2b4c1280977fb0ea25b26b25ce96 /default.nix
parent0abcd8c9581f0017cb2bd59a09e93800ea8f3b1f (diff)
Add DerivingVia newtype for generic arbitrary
Add a newtype, GenericArbitrary, which can be used with -XDerivingVia to
derive Arbitrary instances for types with Generic, via patching
generic-arbitrary to expose the underlying typeclass it uses for
surfacing the type information.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index 7cf9f4beb451..ca163c8e56d7 100644
--- a/default.nix
+++ b/default.nix
@@ -1,8 +1,11 @@
-{ nixpkgs ? import ./nixpkgs.nix {}, compiler ? "ghc865" }:
+{ nixpkgs ? import ./nixpkgs.nix {}
+, compiler ? "ghc865" }:
 let
   inherit (nixpkgs) pkgs;
   all-hies = import (fetchTarball "https://github.com/infinisil/all-hies/tarball/master") {};
   hie = all-hies.selection { selector = p: { inherit (p) ghc865; }; };
-  xanthous = pkgs.haskellPackages.callPackage (import ./pkg.nix { inherit nixpkgs; }) {};
+  xanthous = (pkgs.haskellPackages
+    .extend (import ./haskell-overlay.nix { inherit nixpkgs; }))
+    .callPackage (import ./pkg.nix { inherit nixpkgs; }) {};
 in
 xanthous // { inherit hie; }