about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@gmail.com>2018-03-09T10·32+0100
committerVincent Ambo <github@tazj.in>2018-03-09T12·35+0100
commit4b1d44f71bf243a86b90d047ef65d5b418b4f5bd (patch)
treeaf1995b9f32f479012aec0dfdfaadeb1c3f58822 /default.nix
parent9286e70da371e2dda00ca0d280fcbbb2b2720e80 (diff)
refactor(build): Add Nix derivation & configure Travis to build it
Adds a Nix-derivation for building kontemplate with dependencies
pinned in Nix.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000000..f61d83153d
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,33 @@
+# Copyright (C) 2016-2018  Vincent Ambo <mail@tazj.in>
+#
+# This file is part of Kontemplate.
+#
+# Kontemplate is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This file is the Nix derivation used to install Kontemplate on
+# Nix-based systems.
+
+{ pkgs ? import <nixpkgs> {} }:
+
+with pkgs; buildGoPackage rec {
+  name = "kontemplate-${version}";
+  version = "master";
+  src = ./.;
+  goPackagePath = "github.com/tazjin/kontemplate";
+  goDeps = ./deps.nix;
+
+  # Enable checks and configure check-phase to include vet:
+  doCheck = true;
+  preCheck = ''
+    getGoDirs "" | parallel -j $NIX_BUILD_CORES buildGoDir vet
+  '';
+
+  meta = with lib; {
+    description = "A resource templating helper for Kubernetes";
+    homepage = "http://kontemplate.works/";
+    license = licenses.gpl3;
+  };
+}