about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-09-22T16·19+0100
committerVincent Ambo <tazjin@google.com>2019-09-22T16·19+0100
commit3a79e8b932decec8e238339c80fe7c0516178856 (patch)
treef58dabef2fe9dbfb5b9e9764e1cd751fdb9659b8 /default.nix
parent5b446efb6661f8bfe48136576da25457ea625522 (diff)
refactor(build): Add ciProjects attribute for CI builds r/88
This attribute contains a list of all derivations that should be built
by the CI for this repository.

This includes all of my own packages that are not marked as broken, as
well as select third-party packages.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 8d0ea7e7b5..2b822e7e43 100644
--- a/default.nix
+++ b/default.nix
@@ -77,6 +77,14 @@ let
       inherit (self) lib;
       inherit (super) lispPackages;
     };
+
+    # All projects that should be built by CI should be added here:
+    ciProjects = [
+      self.kontemplate
+      self.nixery
+      self.ormolu
+      self.terraform-gcp
+    ] ++ filter (d: d ? meta.broken && !d.meta.broken) (attrValues self.tazjin);
   };
 
 in { ... } @ args: import stableSrc (args // {