about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-08-25T16·54+0100
committerVincent Ambo <tazjin@google.com>2019-08-25T16·55+0100
commit2fdc87222871e6b68ba2d7ee1c634cfa0d75c572 (patch)
tree66f214b92ee8c4340eaf1ecfd589a05892e7497e /default.nix
parent155f17173b92c892ecd1dbd6af1c9141c6912e33 (diff)
feat(build): Add Terraform from unstable channel r/59
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix25
1 files changed, 18 insertions, 7 deletions
diff --git a/default.nix b/default.nix
index 8eb2695065..caad071c30 100644
--- a/default.nix
+++ b/default.nix
@@ -7,6 +7,21 @@
 with builtins;
 
 let
+  # The pinned commit here is identical to the public nixery.dev
+  # version, since popularity data has been generated for that.
+  stableCommit = "88d9f776091896cfe57dc6fbdf246e7d27d5f105";
+  stableSrc = fetchTarball {
+    url = "https://github.com/NixOS/nixpkgs-channels/archive/${stableCommit}.tar.gz";
+    sha256 = "0z8a0g69fmbbzi77jhvhwafv73dn5fg3gsr0q828lss6j5qpx995";
+  };
+
+  unstableCommit = "765a71f15025ce78024bae3dc4a92bd2be3a8fbf";
+  unstableSrc = fetchTarball {
+    url = "https://github.com/NixOS/nixpkgs-channels/archive/${unstableCommit}.tar.gz";
+    sha256 = "0j1wghr9dj9njn3x9xi0wzjk1107gi2pxb0w2dk8g0djmhnlx71q";
+  };
+  unstable = import unstableSrc {};
+
   localPkgs = super: pkgs: {
     # Local projects should be added here:
     tazjin = {
@@ -17,8 +32,9 @@ let
 
     # Third-party projects (either vendored or modified from nixpkgs) go here:
     gitAppraise = pkgs.callPackage ./third_party/go/git-appraise/git-appraise {};
+
     nixery = import ./third_party/nixery.nix { pkgs = super; };
-    terraform-gcp = pkgs.terraform_0_12.withPlugins(p: [ p.google ]);
+    terraform-gcp = unstable.terraform_0_12.withPlugins(p: [ p.google p.google-beta ]);
     ormolu = import (super.fetchFromGitHub {
       owner = "tweag";
       repo = "ormolu";
@@ -36,12 +52,7 @@ let
     }) {}).elmPackages;
   };
 
-  # The pinned commit here is identical to the public nixery.dev
-  # version, since popularity data has been generated for that.
-  nixpkgsVersion = "88d9f776091896cfe57dc6fbdf246e7d27d5f105";
-  nixpkgs = "https://github.com/NixOS/nixpkgs-channels/archive/${nixpkgsVersion}.tar.gz";
-
-in { ... } @ args: import (fetchTarball nixpkgs) (args // {
+in { ... } @ args: import stableSrc (args // {
     overlays = [ localPkgs ];
     config.allowUnfree = true;
 })