about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-08-19T01·28+0100
committerVincent Ambo <tazjin@google.com>2019-08-19T01·40+0100
commit2e688c18a5c9145826be3d08feeb2a0ba24a86e1 (patch)
tree444c0cf3929f403ffc932289aa79bfa8654aeeb0 /default.nix
parentcb810687d528803cce46cc33c7e33ae8aa23de5d (diff)
feat(third_party): Add nixery with Cachix configuration r/38
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 24d0e02799..e6e19d83aa 100644
--- a/default.nix
+++ b/default.nix
@@ -4,6 +4,8 @@
 # This makes packages accessible via the Nixery instance that is configured to
 # use this repository as its nixpkgs source.
 
+with builtins;
+
 let
   localPkgs = super: pkgs: {
     # Local projects should be added here:
@@ -14,6 +16,7 @@ let
 
     # Third-party projects (either vendored or modified from nixpkgs) go here:
     gitAppraise = pkgs.callPackage ./third_party/go/git-appraise/git-appraise {};
+    nixery = import ./third_party/nixery.nix { pkgs = super; };
     terraform-gcp = pkgs.terraform_0_12.withPlugins(p: [ p.google ]);
   };
 
@@ -22,7 +25,7 @@ let
   nixpkgsVersion = "88d9f776091896cfe57dc6fbdf246e7d27d5f105";
   nixpkgs = "https://github.com/NixOS/nixpkgs-channels/archive/${nixpkgsVersion}.tar.gz";
 
-in { ... } @ args: import (builtins.fetchTarball nixpkgs) (args // {
+in { ... } @ args: import (fetchTarball nixpkgs) (args // {
     overlays = [ localPkgs ];
     config.allowUnfree = true;
 })