about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-03-07T23·10+0300
committerclbot <clbot@tvl.fyi>2023-03-08T10·28+0000
commit252d8b10dbb9bcda496afae1a420d8b115d58175 (patch)
treebfa4b78fe6f864e5c51885c44da8e937cee3cdc0 /default.nix
parent2696839770c1ccb62929ff2575a633c07f5c9593 (diff)
fix: use `depsTargetTargetPropagated` for depot's gcroot r/5900
We've been seeing CI failures after a recent nixpkgs bump which only
occur on canon *after* a CL has been merged. In these CI failures, the
`ci.gcroot` attribute is built to "anchor" the latest canon build, but
fails because it tries to execute random non-executable files (e.g.
the sqlite database produced by //corp/russian/data-import).

From what I can tell, there has been a recent change in nixpkgs where
makeSetupHooks' arguments were restructured. What was previously
`deps` is now `propagatedBuildInputs`, and
`depsTargetTargetPropagated`.

The latter is supposed to be used for non-executable targets,
according to the docs.

This commit changes the entire set to use that flag, as we don't
actually want any executable setup hook - just a gcroot.

Change-Id: Ib258c4f3b09d746c3d000d1c7480d2b4101ab75e
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8227
Autosubmit: tazjin <tazjin@tvl.su>
Reviewed-by: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 2ac136404d..c8d1af9d54 100644
--- a/default.nix
+++ b/default.nix
@@ -118,7 +118,7 @@ readTree.fix (self: (readDepot {
   ci.gcroot = with self.third_party.nixpkgs; makeSetupHook
     {
       name = "depot-gcroot";
-      deps = self.ci.targets;
+      depsTargetTargetPropagated = self.ci.targets;
     }
     emptyFile;
 })