about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-10-16T13·29+0100
committerflokli <flokli@flokli.de>2023-10-30T10·43+0000
commit18d582f96bb8c4351ca3e698c5d192d531883c02 (patch)
tree35faf216028670fa7bd247b1588f7c273f66aa4c /default.nix
parent71fa4110fade5cafe0f1ec4c4a67f0b8bef86a35 (diff)
feat(third_party/nixpkgs): allow setting crossSystem r/6908
This allows cross-compiling depot targets to other architectures, so
`nix-build --argstr crossSystem aarch64-linux -A tvix.nar-bridge`
will emit a cross-compiled aarch64-linux binary.

There's still some other cross-related issues in crate2nix to sort out
for crate2nix builds, but this CL can already land.

Co-Authored-By: raitobezarius <tvl@lahfa.xyz>
Change-Id: I467d49d125dd707a4142bfde18eea4a1c3afaf70
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9755
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 0cb74ee731..c4db2fa580 100644
--- a/default.nix
+++ b/default.nix
@@ -6,6 +6,7 @@
 , parentTargetMap ? null
 , nixpkgsConfig ? { }
 , localSystem ? builtins.currentSystem
+, crossSystem ? null
 , ...
 }@args:
 
@@ -78,7 +79,7 @@ let
 
 in
 readTree.fix (self: (readDepot {
-  inherit localSystem;
+  inherit localSystem crossSystem;
   depot = self;
 
   # Pass third_party as 'pkgs' (for compatibility with external