about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-09-04T11·58+0100
committerVincent Ambo <tazjin@google.com>2019-09-04T11·58+0100
commit16b317fa5af70a5327ff79597e171f3407882cb4 (patch)
tree0d32625b78c4daeb29014c483a8e2e34d9102ab3 /default.nix
parent56f9e3775507def5fb0f69e49c3835b747eba7cd (diff)
chore: Update kontemplate to v1.8.0
This version is agnostic of the working directory even if
insertFile/insertTemplate are used, which makes it a lot nicer to work
with in this repository structure.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix17
1 files changed, 13 insertions, 4 deletions
diff --git a/default.nix b/default.nix
index 3b5736a192..0ace70da5b 100644
--- a/default.nix
+++ b/default.nix
@@ -57,10 +57,19 @@ let
     }) {}).elmPackages;
 
     # Wrap kontemplate to inject the Cloud KMS version of 'pass'
-    kontemplate = self.writeShellScriptBin "kontemplate" ''
-      export PATH="${self.tazjin.kms_pass}/bin:$PATH"
-      exec ${super.kontemplate}/bin/kontemplate $@
-    '';
+    kontemplate =
+      let master = super.kontemplate.overrideAttrs(_: {
+        src = self.fetchFromGitHub {
+          owner = "tazjin";
+          repo = "kontemplate";
+          rev = "v1.8.0";
+          sha256 = "123mjmmm4hynraq1fpn3j5i0a1i87l265kkjraxxxbl0zacv74i1";
+        };
+      });
+      in self.writeShellScriptBin "kontemplate" ''
+        export PATH="${self.tazjin.kms_pass}/bin:$PATH"
+        exec ${master}/bin/kontemplate $@
+      '';
 
     # One of Gemma's dependencies is missing in nixpkgs' Quicklisp
     # package set, it is overlaid locally here.