about summary refs log tree commit diff
path: root/corepkgs/config.nix.in
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2012-06-29T18·26-0400
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-06-29T19·24-0400
commit4911a10a4e51102a21a5d123a852c75d2ec92dbc (patch)
tree6e02ca6d92cc037efc89801960f4997a7d54e168 /corepkgs/config.nix.in
parent49cd7387ad6546571ca31a41f208091b482defaa (diff)
Use XZ compression in binary caches
XZ compresses significantly better than bzip2.  Here are the
compression ratios and execution times (using 4 cores in parallel) on
my /var/run/current-system (3.1 GiB):

  bzip2: total compressed size 849.56 MiB, 30.8% [2m08]
  xz -6: total compressed size 641.84 MiB, 23.4% [6m53]
  xz -7: total compressed size 621.82 MiB, 22.6% [7m19]
  xz -8: total compressed size 599.33 MiB, 21.8% [7m18]
  xz -9: total compressed size 588.18 MiB, 21.4% [7m40]

Note that compression takes much longer.  More importantly, however,
decompression is much faster:

  bzip2: 1m47.274s
  xz -6: 0m55.446s
  xz -7: 0m54.119s
  xz -8: 0m52.388s
  xz -9: 0m51.842s

The only downside to using -9 is that decompression takes a fair
amount (~65 MB) of memory.
Diffstat (limited to 'corepkgs/config.nix.in')
-rw-r--r--corepkgs/config.nix.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/corepkgs/config.nix.in b/corepkgs/config.nix.in
index b324d732a1a2..1be4bd0904ba 100644
--- a/corepkgs/config.nix.in
+++ b/corepkgs/config.nix.in
@@ -6,7 +6,8 @@ in {
   perl = "@perl@";
   shell = "@shell@";
   coreutils = "@coreutils@";
-  bzip2 = fromEnv "NIX_BZIP2" "@bzip2@";
+  bzip2 = "@bzip2@";
+  xz = "@xz@";
   tar = "@tar@";
   tr = "@tr@";
   nixBinDir = fromEnv "NIX_BIN_DIR" "@bindir@";