about summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2006-05-12T11·47+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2006-05-12T11·47+0000
commitb5988004d64d6c533e8bb09732a6f7cd4fb1194f (patch)
treeb8768d77c2a3a3557436e22997c3128ed069fda7 /Makefile.am
parent9d72bf8835f3012169aaa88ec608172d5a056b9e (diff)
* Support for srcdir != builddir (NIX-41).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index d2f483f114..5734cbd79d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,9 +14,9 @@ relname:
 
 install-data-local: init-state
 	$(INSTALL) -d $(DESTDIR)$(sysconfdir)/nix
-	$(INSTALL_DATA) nix.conf.example $(DESTDIR)$(sysconfdir)/nix
+	$(INSTALL_DATA) $(srcdir)/nix.conf.example $(DESTDIR)$(sysconfdir)/nix
 	if ! test -e $(DESTDIR)$(sysconfdir)/nix/nix.conf; then \
-		$(INSTALL_DATA) nix.conf.example $(DESTDIR)$(sysconfdir)/nix/nix.conf; \
+		$(INSTALL_DATA) $(srcdir)/nix.conf.example $(DESTDIR)$(sysconfdir)/nix/nix.conf; \
 	fi
 
 if INIT_STATE
@@ -50,4 +50,4 @@ svn-revision:
 all-local: NEWS
 
 NEWS: doc/manual/NEWS.txt
-	cp doc/manual/NEWS.txt NEWS
+	cp $(srcdir)/doc/manual/NEWS.txt NEWS