about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2018-09-04T10·33+0200
committerVincent Ambo <mail@tazj.in>2018-09-04T10·45+0200
commitdd527ecdf1f8c979a06ade426c22d37c2a4a06ea (patch)
treefd813ab4fb64772ea0504d4adfd75127ac6cd82f /Cargo.toml
parentae409995ca045c77e759a68512125e71b0f14d90 (diff)
feat: Implement claim validation
Implements initial validations of token claims. The included
validations are:

* validation of token issuer
* validation of token audience
* validation that a subject is set
* validation that a token is not expired
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2b7bb7b82d..15eccc357a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -4,8 +4,8 @@ version = "0.1.0"
 authors = ["Vincent Ambo <vincent@aprila.no>"]
 
 [dependencies]
+base64 = "0.9"
 openssl = "0.10"
 serde = "1.0"
-serde_json = "1.0"
 serde_derive = "1.0"
-base64 = "0.9"
+serde_json = "1.0"