about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-with-in-list.nix
# This code causes a situation where a list element causes an
# additional phantom value to temporarily be placed on the locals
# stack, which must be correctly accounted for by the compiler.

let
  set = {
    value = 2;
  };
in
[
  1
  (with set; value)
  3
]