about summary refs log tree commit diff
path: root/third_party/lisp/md5.nix
# MD5 hash implementation
{ depot, pkgs, ... }:

with depot.nix;

let src = with pkgs; srcOnly lispPackages.md5;
in buildLisp.library {
  name = "md5";
  deps = [
    {
      sbcl = buildLisp.bundled "sb-rotate-byte";
      default = depot.third_party.lisp.flexi-streams;
    }
  ];
  srcs = [ (src + "/md5.lisp") ];
}