about summary refs log tree commit diff
path: root/third_party/lisp/local-time.nix
# Library for manipulating dates & times
{ depot, pkgs, ... }:

let
  inherit (depot.nix) buildLisp;
  src = with pkgs; srcOnly lispPackages.local-time;
in
buildLisp.library {
  name = "local-time";
  deps = [
    depot.third_party.lisp.cl-fad
    {
      scbl = buildLisp.bundled "uiop";
      default = buildLisp.bundled "asdf";
    }
  ];

  srcs = [
    "${src}/src/package.lisp"
    "${src}/src/local-time.lisp"
  ];
}