tag
title
# main part of the page, usually wrapped with
, content
# optional extra html to inject into
, extraHead ? null
# whether to use global URLs instead of absolute paths
, useUrls ? false
}@args:
let
inherit (pkgs) writeText lib;
baseUrl = lib.optionalString useUrls "https://tvl.fyi";
in
writeText "index.html" (''
${title}
'' + lib.optionalString (args ? extraHead) extraHead + ''