about summary refs log tree commit diff
path: root/yants-tests.nix
diff options
context:
space:
mode:
Diffstat (limited to 'yants-tests.nix')
-rw-r--r--yants-tests.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/yants-tests.nix b/yants-tests.nix
index 8847758ced8a..e089aab4670a 100644
--- a/yants-tests.nix
+++ b/yants-tests.nix
@@ -45,4 +45,10 @@ deepSeq rec {
     blue = throw "It should not be blue!";
     green = throw "It should not be green!";
   };
+
+  # Test curried function definitions
+  func = defun [ string int string ]
+  (name: age: "${name} is ${toString age} years old");
+
+  testFunc = func "Brynhjulf" 42;
 } "All tests passed!\n"