about summary refs log tree commit diff
path: root/xanthous.nix
diff options
context:
space:
mode:
Diffstat (limited to 'xanthous.nix')
-rw-r--r--xanthous.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/xanthous.nix b/xanthous.nix
deleted file mode 100644
index a10ed48305bb..000000000000
--- a/xanthous.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{ mkDerivation, ascii-art-to-unicode, base, brick, classy-prelude
-, constraints, containers, data-default, deepseq, hpack, lens, mtl
-, QuickCheck, stdenv, tasty, tasty-hunit, tasty-quickcheck, vty
-}:
-let
-  pkgs = import <nixpkgs> {};
-  all-hies = import (fetchTarball "https://github.com/infinisil/all-hies/tarball/master") {};
-  hie = all-hies.selection { selector = p: { inherit (p) ghc865; }; };
-in
-mkDerivation {
-  pname = "xanthous";
-  version = "0.1.0.0";
-  src = ./.;
-  libraryHaskellDepends = [
-    ascii-art-to-unicode base brick classy-prelude constraints
-    containers data-default deepseq lens mtl QuickCheck vty
-  ];
-  libraryToolDepends = [ hpack ];
-  testHaskellDepends = [
-    ascii-art-to-unicode base brick classy-prelude constraints
-    containers data-default deepseq lens mtl QuickCheck tasty
-    tasty-hunit tasty-quickcheck
-  ];
-  executableSystemDepends = [ hie pkgs.cabal-install ];
-  preConfigure = "hpack";
-  homepage = "https://github.com/glittershark/xanthous#readme";
-  description = "A WIP TUI RPG";
-  license = stdenv.lib.licenses.gpl3;
-}