about summary refs log tree commit diff
path: root/website/sandbox/shift-time/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'website/sandbox/shift-time/default.nix')
-rw-r--r--website/sandbox/shift-time/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/website/sandbox/shift-time/default.nix b/website/sandbox/shift-time/default.nix
new file mode 100644
index 000000000000..356c250c7134
--- /dev/null
+++ b/website/sandbox/shift-time/default.nix
@@ -0,0 +1,28 @@
+let
+  briefcase = import /home/wpcarro/briefcase {};
+in briefcase.buildHaskell.program {
+  name = "shift-time";
+  srcs = builtins.path {
+    path = ./.;
+    name = "shift-time-src";
+  };
+  ghcExtensions = [
+    "OverloadedStrings"
+    "NoImplicitPrelude"
+    "RecordWildCards"
+    "TypeApplications"
+  ];
+  deps = hpkgs: with hpkgs; [
+    servant-server
+    aeson
+    wai-cors
+    warp
+    jwt
+    unordered-containers
+    base64
+    http-conduit
+    rio
+    envy
+    req
+  ];
+}