about summary refs log tree commit diff
path: root/website/days-of-week-habits/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'website/days-of-week-habits/default.nix')
-rw-r--r--website/days-of-week-habits/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/website/days-of-week-habits/default.nix b/website/days-of-week-habits/default.nix
new file mode 100644
index 000000000000..f4d3318439d1
--- /dev/null
+++ b/website/days-of-week-habits/default.nix
@@ -0,0 +1,19 @@
+{ pkgs, ... }:
+
+pkgs.stdenv.mkDerivation {
+  name = "typescript";
+  srcs = ./.;
+  buildInputs = with pkgs; [
+    nodejs
+    # Exposes lscpu for parcel.js
+    utillinux
+  ];
+  # parcel.js needs number of CPUs
+  PARCEL_WORKERS = "1";
+  buildPhase = ''
+    npx parcel build src/index.html --public-url ./
+  '';
+  installPhase = ''
+    mv dist $out
+  '';
+}