about summary refs log tree commit diff
path: root/web/tazblog/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'web/tazblog/shell.nix')
-rw-r--r--web/tazblog/shell.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/web/tazblog/shell.nix b/web/tazblog/shell.nix
new file mode 100644
index 0000000000..ebb891a874
--- /dev/null
+++ b/web/tazblog/shell.nix
@@ -0,0 +1,11 @@
+{ pkgs ? (import ../../default.nix {}).third_party.nixpkgs }:
+
+let tazblog = import ./tazblog.nix;
+    depNames = with builtins; filter (
+      p: hasAttr p pkgs.haskellPackages
+    ) (attrNames (functionArgs tazblog));
+    ghc = pkgs.ghc.withPackages(p: map (x: p."${x}") depNames);
+in pkgs.stdenv.mkDerivation {
+  name = "shell";
+  buildInputs = [ ghc pkgs.hlint ];
+}