about summary refs log tree commit diff
path: root/web/tazblog/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'web/tazblog/default.nix')
-rw-r--r--web/tazblog/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/web/tazblog/default.nix b/web/tazblog/default.nix
new file mode 100644
index 0000000000..eecadff6ba
--- /dev/null
+++ b/web/tazblog/default.nix
@@ -0,0 +1,18 @@
+# Build configuration for the blog using plain Nix.
+#
+# tazblog.nix was generated using cabal2nix.
+
+{ pkgs, ... }:
+
+let
+  inherit (pkgs.third_party) writeShellScriptBin haskell;
+  tazblog = haskell.packages.ghc865.callPackage ./tazblog.nix {};
+  wrapper =  writeShellScriptBin "tazblog" ''
+    export PORT=8000
+    export RESOURCE_DIR=${./static}
+    exec ${tazblog}/bin/tazblog
+  '';
+in wrapper.overrideAttrs(_: {
+  allowSubstitutes = true;
+  meta.enableCI = true;
+})