about summary refs log tree commit diff
path: root/web/homepage/nginx.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--web/homepage/nginx.nix12
1 files changed, 5 insertions, 7 deletions
diff --git a/web/homepage/nginx.nix b/web/homepage/nginx.nix
index 90a13a1e98..33b89ee7cc 100644
--- a/web/homepage/nginx.nix
+++ b/web/homepage/nginx.nix
@@ -6,7 +6,7 @@
   writeText, writeShellScriptBin, nginx, lib,
 
   # website content
-  blog
+  blog, website
 }:
 
 let
@@ -44,15 +44,13 @@ let
 
       server {
         listen 8080 default_server;
-        root ${blog.rendered};
-
-        location /static {
-          alias ${blog.static}/;
-        }
+        root ${website};
 
         ${oldRedirects}
 
-        location / {
+        location /blog {
+          alias ${blog.rendered};
+
           if ($request_uri ~ ^/(.*)\.html$) {
             return 302 /$1;
           }