about summary refs log tree commit diff
path: root/web/homepage/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'web/homepage/default.nix')
-rw-r--r--web/homepage/default.nix20
1 files changed, 10 insertions, 10 deletions
diff --git a/web/homepage/default.nix b/web/homepage/default.nix
index e7190bbc9d..d2905a7eb6 100644
--- a/web/homepage/default.nix
+++ b/web/homepage/default.nix
@@ -46,16 +46,16 @@ let
   });
 
   entryToDiv = defun [ entry string ] (entry: ''
-    <div class="entry ${entry.class}">
-      <p>
-        <a class="entry-title" href="${entry.url}">${escape entry.title}</a>
-      </p>
-      ${
-        lib.optionalString ((entry ? description) && (entry.description != null))
-        "<p class=\"entry-description\">${escape entry.description}</p>"
-      }
-      <p class="entry-date">${formatEntryDate entry}</p>
-    </div>
+    <a href="${entry.url}" class="entry ${entry.class}">
+      <div>
+        <p class="entry-title">${escape entry.title}</p>
+        ${
+          lib.optionalString ((entry ? description) && (entry.description != null))
+          "<p class=\"entry-description\">${escape entry.description}</p>"
+        }
+        <p class="entry-date">${formatEntryDate entry}</p>
+      </div>
+    </a>
   '');
 
   index = entries: third_party.writeText "index.html" (lib.concatStrings (