about summary refs log tree commit diff
path: root/web/homepage/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'web/homepage/default.nix')
-rw-r--r--web/homepage/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/web/homepage/default.nix b/web/homepage/default.nix
new file mode 100644
index 0000000000..94dfaf3dc6
--- /dev/null
+++ b/web/homepage/default.nix
@@ -0,0 +1,15 @@
+# Assembles the website index and configures an nginx instance to
+# serve it.
+#
+# The website is made up of a simple header&footer and content
+# elements for things such as blog posts and projects.
+#
+# Content for the blog is in //web/blog instead of here.
+{ pkgs, lib, ... }:
+
+with pkgs;
+with nix.yants;
+
+third_party.callPackage ./nginx.nix {
+  blog = web.blog;
+}