about summary refs log tree commit diff
path: root/web/converse/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'web/converse/default.nix')
-rw-r--r--web/converse/default.nix21
1 files changed, 5 insertions, 16 deletions
diff --git a/web/converse/default.nix b/web/converse/default.nix
index 24d24cf035..a750671196 100644
--- a/web/converse/default.nix
+++ b/web/converse/default.nix
@@ -1,18 +1,7 @@
-# This Nix derivation imports the generated Carnix sources and builds
-# Converse.
-#
-# To work around an issue in Carnix ([1] & [2]) the attributes of the
-# comrak crate have been overridden with a dummy environment variable
-# to simulate a Cargo-based build. This requires a manual change to
-# `Cargo.nix` when updating dependencies.
-#
-# [1]: https://nest.pijul.com/pmeunier/carnix/discussions/2
-# [2]: https://nest.pijul.com/pmeunier/carnix/discussions/3
+{ pkgs, ... }:
 
-{ pkgs ? import <nixpkgs> {}, ... }:
-
-let cargo = pkgs.callPackage ./Cargo.nix {};
-in {
-  # Build is not yet fixed up for the depot.
-  meta.ci = false;
+pkgs.naersk.buildPackage {
+  src = ./.;
+  buildInputs = with pkgs; [ openssl postgresql.lib ];
+  nativeBuildInputs = [ pkgs.pkgconfig ];
 }