about summary refs log tree commit diff
path: root/web/cgit-taz/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'web/cgit-taz/default.nix')
-rw-r--r--web/cgit-taz/default.nix18
1 files changed, 6 insertions, 12 deletions
diff --git a/web/cgit-taz/default.nix b/web/cgit-taz/default.nix
index 962efab91ac7..c2dd7a4a4730 100644
--- a/web/cgit-taz/default.nix
+++ b/web/cgit-taz/default.nix
@@ -9,21 +9,15 @@
 with pkgs.third_party;
 
 let
-  # Patched version of cgit that has monorepo-specific features.
-  monocgit = cgit.overrideAttrs(old: {
-    patches = old.patches ++ [
-      ./0001-cgit_monorepo_urls.patch
-      ./0002-cgit_subtree_readmes.patch
-      ./0003-cgit_subtree_about_links.patch
-    ];
-  });
-
+  sourceFilter = writeShellScriptBin "cheddar-about" ''
+    exec ${pkgs.tools.cheddar}/bin/cheddar --about-filter $@
+  '';
   cgitConfig = writeText "cgitrc" ''
     # Global configuration
     virtual-root=/
     enable-http-clone=1
     readme=:README.md
-    about-filter=${pkgs.tools.cheddar}/bin/cheddar
+    about-filter=${sourceFilter}/bin/cheddar-about
     source-filter=${pkgs.tools.cheddar}/bin/cheddar
     enable-log-filecount=1
     enable-log-linecount=1
@@ -42,7 +36,7 @@ let
 
   thttpdConfig = writeText "thttpd.conf" ''
     port=8080
-    dir=${monocgit}/cgit
+    dir=${cgit}/cgit
     nochroot
     novhost
     logfile=/dev/stdout
@@ -77,4 +71,4 @@ let
   });
 in writeShellScriptBin "cgit-launch" ''
   exec ${thttpdCgit}/bin/thttpd -D -C ${thttpdConfig}
-# ''
+''