about summary refs log tree commit diff
path: root/web/cgit-taz/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'web/cgit-taz/default.nix')
-rw-r--r--web/cgit-taz/default.nix14
1 files changed, 9 insertions, 5 deletions
diff --git a/web/cgit-taz/default.nix b/web/cgit-taz/default.nix
index 636695c883..f2f47e5793 100644
--- a/web/cgit-taz/default.nix
+++ b/web/cgit-taz/default.nix
@@ -1,11 +1,15 @@
 # This derivation configures a 'cgit' instance to serve repositories
 # from a different source.
-
-{ depot, ... }:
-
-with depot.third_party;
+{ depot, pkgs, ... }:
 
 let
+  inherit (pkgs)
+    mime-types
+    thttpd
+    writeShellScriptBin
+    writeText
+    ;
+
   sourceFilter = writeShellScriptBin "cheddar-about" ''
     exec ${depot.tools.cheddar}/bin/cheddar --about-filter $@
   '';
@@ -33,7 +37,7 @@ let
 
   thttpdConfig = writeText "thttpd.conf" ''
     port=2448
-    dir=${cgit}/cgit
+    dir=${depot.third_party.cgit}/cgit
     nochroot
     novhost
     cgipat=**.cgi