about summary refs log tree commit diff
path: root/web/bubblegum/examples/derivation-svg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'web/bubblegum/examples/derivation-svg.nix')
-rw-r--r--web/bubblegum/examples/derivation-svg.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/web/bubblegum/examples/derivation-svg.nix b/web/bubblegum/examples/derivation-svg.nix
new file mode 100644
index 0000000000..a5f30a2bd1
--- /dev/null
+++ b/web/bubblegum/examples/derivation-svg.nix
@@ -0,0 +1,11 @@
+# Warning: this is *very* slow on the first request
+{ depot, ... }:
+
+let
+  inherit (depot.web.bubblegum)
+    respond
+    ;
+in
+  respond "OK" {
+    Content-type = "image/svg+xml";
+  } (builtins.readFile "${depot.tvix.docs.svg}/component-flow.svg")