about summary refs log tree commit diff
path: root/web/blog/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'web/blog/default.nix')
-rw-r--r--web/blog/default.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/web/blog/default.nix b/web/blog/default.nix
index bc7b9666f7..1bc026bf2a 100644
--- a/web/blog/default.nix
+++ b/web/blog/default.nix
@@ -11,7 +11,7 @@ let
   post = struct "blog-post" {
     key = string; #
     title = string;
-    date = string; # *sigh*
+    date = int;
 
     # Path to the Markdown file containing the post content.
     content = path;
@@ -39,8 +39,7 @@ let
     ${lib.concatStringsSep "\n" (map (post:
       "cp ${fragments.renderPost post} $out/${post.key}.html"
     ) posts)}
-  ''; # '' (this line makes nix-mode happy :/)
-
+  '';
 in import ./nginx.nix (args // {
   inherit posts renderedBlog;
 })