about summary refs log tree commit diff
path: root/views/tvix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'views/tvix/default.nix')
-rw-r--r--views/tvix/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/views/tvix/default.nix b/views/tvix/default.nix
new file mode 100644
index 000000000000..33d6b6368668
--- /dev/null
+++ b/views/tvix/default.nix
@@ -0,0 +1,24 @@
+# Externally importable TVL depot stack. This is intended to be called
+# with a supplied package set, otherwise the package set currently in
+# use by the TVL depot will be used.
+#
+{ pkgs ? (import ./nixpkgs {
+    depotOverlays = false;
+    depot.third_party.sources = import ./sources { };
+  })
+, ...
+}:
+
+pkgs.mkShell {
+  name = "tvix-rust-dev-env";
+  packages = [
+    pkgs.buf-language-server
+    pkgs.cargo
+    pkgs.clippy
+    pkgs.rust-analyzer
+    pkgs.rustc
+    pkgs.rustfmt
+    pkgs.protobuf
+    pkgs.evans
+  ];
+}