about summary refs log tree commit diff
path: root/users/wpcarro/utils/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/wpcarro/utils/default.nix')
-rw-r--r--users/wpcarro/utils/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/users/wpcarro/utils/default.nix b/users/wpcarro/utils/default.nix
new file mode 100644
index 0000000000..46d30acfa2
--- /dev/null
+++ b/users/wpcarro/utils/default.nix
@@ -0,0 +1,15 @@
+args@{ pkgs, ... }:
+
+# This top-level module exposes all of my utility functions for Nix. It should
+# be used like:
+# ```nix
+# inherit (depot.users.wpcarro.utils) fs;
+# ```
+
+let
+  builder = import ./builder.nix args;
+  fs = import ./fs.nix args;
+in
+{
+  inherit builder fs;
+}