about summary refs log tree commit diff
path: root/users/wpcarro/third_party/lisp/anaphora.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/wpcarro/third_party/lisp/anaphora.nix')
-rw-r--r--users/wpcarro/third_party/lisp/anaphora.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/users/wpcarro/third_party/lisp/anaphora.nix b/users/wpcarro/third_party/lisp/anaphora.nix
new file mode 100644
index 0000000000..bf4bf663f4
--- /dev/null
+++ b/users/wpcarro/third_party/lisp/anaphora.nix
@@ -0,0 +1,17 @@
+{ depot, ... }:
+
+let
+  src = builtins.fetchGit {
+    url = "https://github.com/tokenrove/anaphora.git";
+    rev = "aeace4c68cf55098a67112750b28f8f2dc6d0e30";
+  };
+in depot.nix.buildLisp.library {
+  name = "anaphora";
+  deps = [];
+  srcs = [
+    "${src}/packages.lisp"
+    "${src}/early.lisp"
+    "${src}/symbolic.lisp"
+    "${src}/anaphora.lisp"
+  ];
+}