about summary refs log tree commit diff
path: root/users/wpcarro/scratch/haskell-programming-from-first-principles/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/wpcarro/scratch/haskell-programming-from-first-principles/shell.nix')
-rw-r--r--users/wpcarro/scratch/haskell-programming-from-first-principles/shell.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/users/wpcarro/scratch/haskell-programming-from-first-principles/shell.nix b/users/wpcarro/scratch/haskell-programming-from-first-principles/shell.nix
new file mode 100644
index 0000000000..b594a4207e
--- /dev/null
+++ b/users/wpcarro/scratch/haskell-programming-from-first-principles/shell.nix
@@ -0,0 +1,8 @@
+let
+  briefcase = import <briefcase> {};
+in briefcase.buildHaskell.shell {
+  deps = hpkgs: with hpkgs; [
+    quickcheck-simple
+    checkers
+  ];
+}