about summary refs log tree commit diff
path: root/users/wpcarro/scratch/blockchain/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/wpcarro/scratch/blockchain/default.nix')
-rw-r--r--users/wpcarro/scratch/blockchain/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/users/wpcarro/scratch/blockchain/default.nix b/users/wpcarro/scratch/blockchain/default.nix
new file mode 100644
index 0000000000..745e7a5ab4
--- /dev/null
+++ b/users/wpcarro/scratch/blockchain/default.nix
@@ -0,0 +1,13 @@
+{ pkgs, ... }:
+
+let
+  pypkgs = pkgs.python3Packages;
+in pkgs.python3Packages.buildPythonApplication {
+  pname = "main";
+  src = ./.;
+  version = "0.0.1";
+  propagatedBuildInputs = with pypkgs; [
+    flask
+    requests
+  ];
+}