about summary refs log tree commit diff
path: root/users/wpcarro/nixos/marcus/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/wpcarro/nixos/marcus/default.nix')
-rw-r--r--users/wpcarro/nixos/marcus/default.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/users/wpcarro/nixos/marcus/default.nix b/users/wpcarro/nixos/marcus/default.nix
index bfbc392c21e8..f3c76f16c547 100644
--- a/users/wpcarro/nixos/marcus/default.nix
+++ b/users/wpcarro/nixos/marcus/default.nix
@@ -67,7 +67,10 @@ in {
   users.mutableUsers = true;
   users.users.wpcarro = {
     isNormalUser = true;
-    extraGroups = [ "wheel" ];
+    extraGroups = [
+      "wheel"
+      "video" # needed to control the screen brightness
+    ];
     shell = pkgs.fish;
   };
 
@@ -83,7 +86,10 @@ in {
     };
   };
 
-  programs.fish.enable = true;
+  programs = {
+    fish.enable = true;
+    light.enable = true;
+  };
 
   environment.systemPackages = with pkgs; [
     alacritty