about summary refs log tree commit diff
path: root/users/wpcarro/nixos/diogenes/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/wpcarro/nixos/diogenes/default.nix')
-rw-r--r--users/wpcarro/nixos/diogenes/default.nix58
1 files changed, 58 insertions, 0 deletions
diff --git a/users/wpcarro/nixos/diogenes/default.nix b/users/wpcarro/nixos/diogenes/default.nix
new file mode 100644
index 0000000000..076261eb50
--- /dev/null
+++ b/users/wpcarro/nixos/diogenes/default.nix
@@ -0,0 +1,58 @@
+{ depot, pkgs, ... }:
+{ ... }:
+
+let
+  inherit (depot.users.wpcarro) keys;
+in {
+  imports = [
+    (pkgs.path + "/nixos/modules/virtualisation/google-compute-image.nix")
+  ];
+
+  networking.hostName = "diogenes";
+
+  # Use the TVL binary cache
+  tvl.cache.enable = true;
+
+  # Use 100G volume for /nix
+  fileSystems."/nix" = {
+    device = "/dev/disk/by-uuid/62396bde-9002-4025-83eb-2a6c731b7adc";
+    fsType = "ext4";
+  };
+
+  users = {
+    mutableUsers = true;
+    users = {
+      wpcarro = {
+        isNormalUser = true;
+        extraGroups = [ "wheel" ];
+        openssh.authorizedKeys.keys = keys.all;
+        shell = pkgs.fish;
+      };
+    };
+  };
+
+
+  security.sudo.wheelNeedsPassword = false;
+
+  environment.systemPackages = with pkgs; [
+    fd
+    fzf
+    mkpasswd
+    ripgrep
+    tldr
+    tree
+    vim
+  ];
+
+  services = {
+    depot.automatic-gc = {
+      enable = true;
+      interval = "1 hour";
+      diskThreshold = 16; # GiB
+      maxFreed = 10; # GiB
+      preserveGenerations = "14d";
+    };
+  };
+
+  system.stateVersion = "21.11";
+}