about summary refs log tree commit diff
path: root/users/wpcarro/emacs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/wpcarro/emacs/default.nix')
-rw-r--r--users/wpcarro/emacs/default.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/users/wpcarro/emacs/default.nix b/users/wpcarro/emacs/default.nix
index c2669f6949..b751849eab 100644
--- a/users/wpcarro/emacs/default.nix
+++ b/users/wpcarro/emacs/default.nix
@@ -18,7 +18,8 @@ let
       pass
       scrot
       xorg.xset
-    ]));
+    ])
+  );
 
   emacsWithPackages = (emacsPackagesGen emacs27).emacsWithPackages;
 
@@ -128,7 +129,7 @@ let
   makeEnvVars = env: concatStringsSep "\n"
     (mapAttrsToList (k: v: "export ${k}=\"${v}\"") env);
 
-  withEmacsPath = { emacsBin, env ? {}, load ? [] }:
+  withEmacsPath = { emacsBin, env ? { }, load ? [ ] }:
     writeShellScriptBin "wpcarros-emacs" ''
       export XMODIFIERS=emacs
       export PATH="${emacsBinPath}:$PATH"
@@ -143,16 +144,17 @@ let
         ${concatStringsSep "\n" (map (el: "--load ${el} \\") load)}
         "$@"
     '';
-in {
+in
+{
   inherit withEmacsPath;
 
-  nixos = { load ? [] }: withEmacsPath {
+  nixos = { load ? [ ] }: withEmacsPath {
     inherit load;
     emacsBin = "${wpcarrosEmacs}/bin/emacs";
   };
 
   # Script that asserts my Emacs can initialize without warnings or errors.
-  check = runCommand "check-emacs" {} ''
+  check = runCommand "check-emacs" { } ''
     # Even though Buildkite defines this, I'd still like still be able to test
     # this locally without depending on my ability to remember to set CI=true.
     export CI=true