about summary refs log tree commit diff
path: root/users/wpcarro/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/wpcarro/common.nix')
-rw-r--r--users/wpcarro/common.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/users/wpcarro/common.nix b/users/wpcarro/common.nix
new file mode 100644
index 0000000000..79e2eecf5a
--- /dev/null
+++ b/users/wpcarro/common.nix
@@ -0,0 +1,27 @@
+{ pkgs, ... }:
+
+{
+  # Command-line tools I commonly used and want available on most (or all) of my
+  # machines.
+  shell-utils = with pkgs; [
+    bat
+    dig
+    direnv
+    diskus
+    emacs
+    exa
+    fd
+    fzf
+    git
+    jq
+    mkpasswd
+    nmap
+    python3
+    ripgrep
+    tldr
+    tokei
+    tree
+    vim
+    xclip
+  ];
+}