about summary refs log tree commit diff
path: root/users/wpcarro/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/wpcarro/common.nix')
-rw-r--r--users/wpcarro/common.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/users/wpcarro/common.nix b/users/wpcarro/common.nix
index 7093b5f1d4..b8ecc6843c 100644
--- a/users/wpcarro/common.nix
+++ b/users/wpcarro/common.nix
@@ -1,6 +1,25 @@
 { pkgs, ... }:
 
 {
+  programs = {
+    fish.enable = true;
+
+    ssh = {
+      startAgent = true;
+      extraConfig = ''
+        AddKeysToAgent yes
+      '';
+    };
+
+    git = {
+      enable = true;
+      config = {
+        user.name = "William Carroll";
+        user.email = "wpcarro@gmail.com";
+      };
+    };
+  };
+
   services = {
     depot.automatic-gc = {
       enable = true;