about summary refs log tree commit diff
path: root/users/wpcarro/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/wpcarro/common.nix')
-rw-r--r--users/wpcarro/common.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/users/wpcarro/common.nix b/users/wpcarro/common.nix
index 79e2eecf5a..7093b5f1d4 100644
--- a/users/wpcarro/common.nix
+++ b/users/wpcarro/common.nix
@@ -1,6 +1,16 @@
 { pkgs, ... }:
 
 {
+  services = {
+    depot.automatic-gc = {
+      enable = true;
+      interval = "1 hour";
+      diskThreshold = 16; # GiB
+      maxFreed = 10; # GiB
+      preserveGenerations = "14d";
+    };
+  };
+
   # Command-line tools I commonly used and want available on most (or all) of my
   # machines.
   shell-utils = with pkgs; [