about summary refs log tree commit diff
path: root/users/wpcarro/ci/pipelines/post-receive.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/wpcarro/ci/pipelines/post-receive.nix')
-rw-r--r--users/wpcarro/ci/pipelines/post-receive.nix25
1 files changed, 1 insertions, 24 deletions
diff --git a/users/wpcarro/ci/pipelines/post-receive.nix b/users/wpcarro/ci/pipelines/post-receive.nix
index ee4850aa8b..64401dee4a 100644
--- a/users/wpcarro/ci/pipelines/post-receive.nix
+++ b/users/wpcarro/ci/pipelines/post-receive.nix
@@ -16,14 +16,6 @@ let
       label = ":broom: lint secrets";
     }
     {
-      key = "build-briefcase";
-      command = ''
-        nix-build . -I briefcase="$(pwd)" --no-out-link --show-trace
-      '';
-      label = ":nix: build briefcase";
-      depends_on = "lint-secrets";
-    }
-    {
       key = "init-emacs";
       command = let
         scriptEl = path {
@@ -32,25 +24,10 @@ let
         };
         runScriptEl = runScript {
           script = scriptEl;
-          briefcasePath = "$(pwd)";
         };
       in "${runScriptEl} ${initEl}";
       label = ":gnu: initialize Emacs";
-      depends_on = "build-briefcase";
-    }
-    {
-      key = "build-socrates";
-      command = ''
-        nix-build '<nixpkgs/nixos>' \
-          -I briefcase="$(pwd)" \
-          -I nixpkgs=/var/lib/buildkite-agent-socrates/nixpkgs-channels \
-          -I nixos-config=nixos/socrates/default.nix \
-          -A system \
-          --no-out-link \
-          --show-trace
-      '';
-      label = ":nix: build socrates";
-      depends_on = "build-briefcase";
+      depends_on = "lint-secrets";
     }
   ];
 in pkgs.writeText "pipeline.yaml" (toJSON pipeline)