about summary refs log tree commit diff
path: root/users/tazjin/nixos/tverskoy/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tazjin/nixos/tverskoy/default.nix')
-rw-r--r--users/tazjin/nixos/tverskoy/default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/users/tazjin/nixos/tverskoy/default.nix b/users/tazjin/nixos/tverskoy/default.nix
index b691fce379..9fe3244683 100644
--- a/users/tazjin/nixos/tverskoy/default.nix
+++ b/users/tazjin/nixos/tverskoy/default.nix
@@ -339,6 +339,7 @@ in lib.fix(self: {
           ".local/share/Steam"
           ".local/share/direnv"
           ".local/share/fish"
+          ".local/share/zoxide"
           ".mozilla/firefox"
           ".password-store"
           ".rustup"
@@ -365,6 +366,13 @@ in lib.fix(self: {
         };
       };
 
+      programs.fish = {
+        enable = true;
+        interactiveShellInit = ''
+          ${pkgs.zoxide}/bin/zoxide init fish | source
+        '';
+      };
+
       services.screen-locker = {
         enable = true;
         enableDetectSleep = true;