about summary refs log tree commit diff
path: root/users/tazjin/nixos/tverskoy/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--users/tazjin/nixos/tverskoy/default.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/users/tazjin/nixos/tverskoy/default.nix b/users/tazjin/nixos/tverskoy/default.nix
index 513f65966fce..53b189565005 100644
--- a/users/tazjin/nixos/tverskoy/default.nix
+++ b/users/tazjin/nixos/tverskoy/default.nix
@@ -97,6 +97,8 @@ lib.fix (self: {
 
     opengl = {
       enable = true;
+      driSupport32Bit = true;
+
       extraPackages = with pkgs; [
         vaapiVdpau
         libvdpau-va-gl
@@ -166,5 +168,7 @@ lib.fix (self: {
   # as I do anything stressful to the machine
   systemd.services.systemd-oomd.enable = lib.mkForce false;
 
+  environment.systemPackages = [ pkgs.vulkan-tools ];
+
   system.stateVersion = "20.09";
 })